Act! Software Licensing issue

By Donald Egen • November 6th, 2018

We have been notified today about an issue with the third-party software component that supports the licensing of all Act! versions between Act! 2005 and Act! v20.

This may affect your ability to take certain common actions with the Act! software and your future ability to access your Act! database.

First off, please see the official announcements from SwiftPage.  These are specific to the versions of Act! being addressed.

  • For currently supported versions v19 and v20, go here.
  • For version 17 and older (versions Act! 2005 to v17), go here.
  • For the announcement specific to version 18, go here.

For the latest information please see this article in the Act! KnowledgeBase.

Now, as always, we are here to assist you.  If you have questions about your specific situation or want to discuss your options please feel free to call us at 423-875-2652 or contact us via our Contact Us page.

Update:  We have been notified of the following anticipated release schedule for fixes for this issue.  As the fixes are actually released we will link to appropriate download pages and installation instructions.

  • For Act! v21.0 – November 20, 2018 (as Update 2)
  • For Act! v20.1 – December 6, 2018 (as Update 8)
  • For Act! v20.0 – December 13, 2018 (as Update 9)
  • For Act! v19.2 – December 20, 2018 (as Update 5)
    • The update for Act! Premuim v19.2 is now available at this page on www.act.com
    • The update for Act! Pro v19.2 is now available at this page on www.act.com.
      • If you are running version 19.0 or 19.1 of Act! Premium or Pro, you are required to upgrade to version 19.2 before installing the licensing update.  The installers to upgrade you to v19.2 are on the same pages linked above.  Just scroll down.
  • For Act! v18.2 – January 8, 2019 (as Update 7)
    • The update is scheduled to be available January 8, 2019

« | Home | »